How to fix under extrusion after travel

3d printers needs to maintain nozzle pressure when extruding. When travelling across empty space the printer stops extruding and retracts. Once it reaches the other side, it needs to recreate the pressure and start extruding again. Often, when it restarts the pressure is not high enough and you get some under extrusion. When this issue occurs, I have found changing the temperature or printing speed does not help.

How do you know if you have this issue: Most of the print is perfect but you will see some wavy lines or thin areas next to your Z seam. The longer the wavy areas, the worse the issue is. If you view travel in your slicer preview you will see the issue occurs right next to the travel lines. In this example it is clear filament is missing, in less extreme cases it is simply wavy:

How to fix it: The issue can be caused by a few different things. Here are a series of causes and what you can do to fix it.

  1. Cause: Pressure loss due to retraction If this happens all the time and isn’t a new issue, then it may simply be that your printer is just losing a little bit of plastic before travelling, and needs a little help creating the pressure again. This is a common issue that is difficult for slicers to solve. If your model is complex and has lots of gap fills the issue is even more likely to occur. The ideal solution to this problem is called linear advance which helps maintain constant pressure. If your printer supports this then you you will want to follow a guide to tuning that for your printer. Unfortunately, boards included with Creality machines including the Ender 3 do not support this (even with a firmware update as the stepper drivers are not compatible with this feature). Instead you will want to turn on extra prime.
    What to try: Add a small amount of extra prime in your slicer, you can try 0.05, 0.1, 0.15 or up to 0.2. If that fixes it, great! If you find you have to go higher than 0.2, then it is likely you have one of the other issues below.
    In PrusaSlicer set this in Printer Settings -> Extra Length on Restart. Click for screenshot

    image

    In Cura it's under Travel -> Retraction Extra Prime Amount. Click for screenshot

    image
    In prusa slicer the setting is found at: “Printer Settings → extra length on restart”. In Cura it is “Travel → retraction extra prime amount”.

    You can also adjust your retraction speed: Retracting or detretracting too fast can cause the printer to skip steps, negating some of the retraction benefits and causing extrusion issues. If your speed is high (say 70 mm/s) try slowing down. We’ve found 35 mm/s to be a good speed for retraction on Creality machines.

  1. Cause: A clog: Dirt and debris build up in the nozzle can cause underextrusion issues like this one.
    What to try: Run a nozzle cleaning needle through the nozzle to clear debris. to Do a cold pull: heat the nozzle and push filament through. Let the nozzle cool (this is to trap dirt in the melted filament). Now heat the nozzle and at around 100 C try to remove the filament by hand, if there is debris on the end cut it off and do the process again until the filament comes out clean. Note: if it is very difficult to remove the filament, even when much hotter than 100, you likely are dealing with the creality bowden gap issue, below.

  2. Cause: Bowden gap. In creality machines and many others, the bowden tube goes down the hot end and touches the nozzle. Over time, due to heat and retractions, the end of the bowden tube will either slip upward or it will simply degrade. In either case a gap will form and plastic will get into the gap causing underextusion.
    What to try: To fix it you need to remove the nozzle, clean the tube, snip the end if it is degraded, and then reseat it properly. To reseat it, tighten the nozzle all the way, then unscrew it one full turn. Now push the bowden tube all the way down. Now retighten the nozzle. More on this here: How to fix under-extrusion caused by bowden gap.

  3. Cause: Difference between the STL blade thickness and line width (extrusion width) in the slicer: For thin walls (like cookie cutters) make your extrusion width (line width in cura) a divisor of your model wall thickness + 0.04. So if your cutter wall in your model is 0.9mm then set perimeter extrusion width (PrusaSlicer: Print settings → advanced. Cura: Quality → Line Width) to 0.49 (this is half the wall width plus 0.04). This will make your walls slightly overlap, avoiding having to do gap fill inside your thin wall and avoiding possible splitting walls.

2 Likes

Hi! :blush:
How will you set the “Line width” if your blade is a double blade or it has an angle to cut?

Let me show an example of a blade with an angle :slightly_smiling_face:
The blade is 1mm but at the end, it has a 75°, so blade goes from 1mm to .4 mm for a better cut.

The same question is, if it has 2 blades, .5 mm each, how can I set the “Line width”

Sorry if this is confused, Im very new to 3D printing, but I’ve been struggling with this for 2 months now :persevere:

Hello. so glad I stumbled across this today, I have been struggling with this exact problem for months now, it doesn’t happen on all my cutters, mainly ones that have tight diameter curves.

I am printing with a flash forge creator pro, do you have any idea on what settings to tweak in flashprint to correct this issue, I had a look but couldn’t find the ones you had suggested in flashprint settings.

thanks so much, its nice to finally know a little more on what the problem is.

I wouldn’t worry about the line width for the tapered blade. That cutter looks great! If you have two blades that are 0.5 mm then your two walls combined are 1mm so a good line width is 0.54. That will make a good 1mm wall with two lines and a slight overlap to avoid gaps. Here are some example line widths:

Cutter wall 0.8 mm - line width 0.44
Cutter wall 0.9 mm - line width 0.49 (This is what we use ourselves)
Cutter wall 1 mm - line width 0.54
Cutter wall 1.2 mm - line width 0.64 or 0.44 (this will make three walls since 0.4 * 3 = 1.2)

If you are having an issue it may not be because of the line width. Post a photo of the problem to help troubleshoot. If it is not this under extrusion issue feel free to start a new topic.

If they have it, it should be under retraction settings. Make sure you have turned on expert mode first (File>Preferences>Print>Printing window type to Expert Mode) as that will show more settings. If there is no extra prime then I would recommend you switch to PrusaSlicer or Cura as those are the most popular slicers and they both have that setting. You will need a slicer profile for the flashforge. It is possible that the slicers come with a profile. After installing the slicer it will let you select your printer - if Flashforge is an option select it. If not, then you can search online, find a profile and import it. You can try googling Cura flashforge or prusaslicer flashforge. Here is a cura tutorial I found. Here is another discussion about this. I am not actually familiar with the flashforge, hopefully one of these works or someone familiar with it can chime in.

Thanks so much for that info. I’ll give it a go with another slicer, will let you know what the results are :grinning_face_with_smiling_eyes: